Results 1 to 7 of 7

Thread: RHEL 5.8: Destination Host Unreachable

  1. #1
    Junior Member
    Join Date
    Sep 2013
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Default RHEL 5.8: Destination Host Unreachable

    Good Afternoon. I am pretty new to linux. I have only been working on it in a data center for a little over a year and now I am in a new position and a new job that requires a little bit of linux use. We do not have a linux sysadmin here and I am not going to training for a few more months. Unfortunately I still have to get some of this stuff working.

    My issue seemed easy at first and I was able to get a lot of info off google but I am not able to get my servers (4) online. I can ping the server itself with 127.0.0.1 but when I ping the gateway I get "Destination host unreachable" When I ping google I get "ping: unknown host google.com"

    I have verified the settings in ifcfg-eth0 to be right, but not sure what else to do from here. Any help would be appreciated. I dont know what all you will need but ill add it as its asked for.

    Thank you


    Forgot to mention that it is currently RHEL 5.8

  2. #2
    Junior Member
    Join Date
    Mar 2012
    Posts
    24
    Thanks
    0
    Thanked 6 Times in 6 Posts
    Rep Power
    0

    Default

    post the contents of
    /etc/sysconfig/network

    /etc/resolv.conf
    /etc/sysconfig/network-scripts/ifcfg-eth0

  3. #3
    Junior Member
    Join Date
    Sep 2013
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Default

    [root@localhost ~]# cat /etc/sysconfig/net
    NETWORKING=yes
    NETWORKING_IPV6=no
    HOSTNAME=localhost.localdomain
    [root@localhost ~]# cat /etc/resolve.conf
    search localdomain
    167.99.57.223
    159.65.199.200
    [root@localhost ~]# cat /etc/sysconfig/network-scripts/ifcg-eth0
    DEVICE=eth0
    BOOTPROTO=none
    ONBOOT=yes
    IPADDR=10.199.199.235
    NETMASK=255.255.254.0
    NETWORK=10.199.198.1
    HWADDR=D8:9D:67:75:6A:88

    We have a lot of virtuals in our environment and im going to assume that this issue may have something to do with the fact it still says root@localhost when all the others say username@servername.

  4. #4
    Never say die nixcraft's Avatar
    Join Date
    Jan 2005
    Location
    BIOS
    Posts
    4,513
    Thanks
    17
    Thanked 804 Times in 511 Posts
    Rep Power
    10

    Default

    Edit /etc/sysconfig/network and make sure GATEWAY (router IP) is set to actual IP of your router. In this example, I am setting default gateway to 192.168.1.254:
    Code:
    GATEWAY=192.168.1.254
    You need to restart the network service:
    Code:
    /etc/init.d/networking restart
    To print current or update routing table:
    Code:
    route -nr
    Test it:
    Code:
    ping gate-way-ip
    ping ns1-ip
    ping 167.99.57.223
    ping cyberciti.biz
    host cyberciti.biz
    See:
    1. Red Hat / CentOS Linux Setting a Default Gateway
    2. Howto Red hat enterprise Linux 5 configure the network card


    HTH
    All [Solved] threads are closed by mods / admin to avoid spam issues. See Howto mark a thread as [Solved]


  5. #5
    Junior Member
    Join Date
    Sep 2013
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Default

    Thank you for the quick reply.

    I added my gateway and restarted network but still getting Destination host Unreachable when I ping the gateway.

    Also, when I tried to use route -nr it said:

    route: invalid option -- r

    then went on listing possible options.

  6. #6
    Never say die nixcraft's Avatar
    Join Date
    Jan 2005
    Location
    BIOS
    Posts
    4,513
    Thanks
    17
    Thanked 804 Times in 511 Posts
    Rep Power
    10

    Default

    My bad try:
    Code:
    netstat -nr
    OR
    Code:
    route -n
    Also remove NETWORK entry. It is not required. Linux will figure out the correct subnet for you.
    Last edited by nixcraft; 17th September 2013 at 09:18 PM.
    All [Solved] threads are closed by mods / admin to avoid spam issues. See Howto mark a thread as [Solved]


  7. #7
    Junior Member
    Join Date
    Sep 2013
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Default

    I have removed the NETWORK field from /etc/sysconfig/network-scripts/ifcfg-eth0

    Here is the results of netstat -nr (its attached as a screenshot because I cannot connect to it remotely via putty so I am using an iLo console that does not allow copy/paste)

    netstat -nr.jpg

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: 16th September 2013, 01:53 AM
  2. Rhel 5 packet loss issues "Destination Host Unreachable"
    By jspcllc in forum CentOS / RHEL / Fedora
    Replies: 2
    Last Post: 25th August 2011, 01:18 PM
  3. Replies: 2
    Last Post: 11th October 2010, 06:46 PM
  4. Replies: 0
    Last Post: 31st July 2008, 02:53 PM
  5. SIOCADDRT Network Unreachable
    By puppen in forum Linux software
    Replies: 5
    Last Post: 19th May 2006, 12:51 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •