Results 1 to 6 of 6

Thread: could not open default font 'fixed'

  1. #1
    Junior Member
    Join Date
    Mar 2010
    Posts
    9
    Thanks
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0

    Default could not open default font 'fixed'

    Hey,

    I'm using RHEL6.1 X64 with RealVNC 4.1.

    while running 'vncserver' command - I receive the following error in the vnc .log file.

    Fatal server error:
    could not open default font 'fixed'



    Could someone please help me out here?


    Thanks.

  2. #2
    Never say die nixcraft's Avatar
    Join Date
    Jan 2005
    Location
    BIOS
    Posts
    4,513
    Thanks
    17
    Thanked 804 Times in 511 Posts
    Rep Power
    10

    Default

    Can you attach or post your xorg.conf from /etc/X11 directory? You need to set FontPath in this file.
    All [Solved] threads are closed by mods / admin to avoid spam issues. See Howto mark a thread as [Solved]


  3. #3
    Junior Member
    Join Date
    Mar 2010
    Posts
    9
    Thanks
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0

    Default

    Quote Originally Posted by nixcraft View Post
    Can you attach or post your xorg.conf from /etc/X11 directory? You need to set FontPath in this file.
    Hey nix and thanks for your quick reply.

    I managed to overcome this issue by linking the font folders to /usr/share/X11/fonts/<font name>

    Now I have a new problem.. graphics seem to be messed up when I open the VNC window

    SC_08.jpg

    Any ideas?

  4. #4
    Junior Member
    Join Date
    Mar 2010
    Posts
    9
    Thanks
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0

    Default

    BTW,

    I'm using the following video card:

    [root@lx1011 fonts]# lspci -v | grep -i vga
    01:03.0 VGA compatible controller: ATI Technologies Inc ES1000 (rev 02) (prog-if 00 [VGA controller])


    and in xorg.conf I think it's defined well:

    Section "Device"
    Identifier "Card0"
    Driver "radeon"
    BusID "PCI:1:3:0"

  5. #5
    Junior Member
    Join Date
    Mar 2010
    Posts
    9
    Thanks
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0

    Default

    Also, while working on the server locally - all graphics seem to be ok.

    It just get messy while using remote VNC.


    Thanks.

  6. #6
    Junior Member
    Join Date
    Mar 2010
    Posts
    9
    Thanks
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0

    Default

    For anyone whois interested to know... I managed to fix it by removing RealVNC and install TigerVNC instead. All graphics glitches are now solved.

    Thanks.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [SOLVED] Setting Font Size in Slackware 13.37
    By timtravlr in forum Slackware
    Replies: 2
    Last Post: 20th August 2011, 01:50 PM
  2. Font rendering
    By vamsi in forum Ubuntu / Debian
    Replies: 1
    Last Post: 4th March 2010, 10:37 PM
  3. [Solved] Change Font Size in Dialog Box ?
    By a31modela in forum Shell scripting
    Replies: 3
    Last Post: 3rd March 2010, 07:07 PM
  4. Put fixed answers instead of promt for user input
    By h.vujcec in forum Shell scripting
    Replies: 0
    Last Post: 28th July 2008, 07:52 PM
  5. Problem fixed
    By vivek in forum Feedback & Site News
    Replies: 0
    Last Post: 11th November 2005, 04:51 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •