Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22

Thread: Linux: NFS4 client unable to mount share

  1. #1
    Senior Member t0kneneng's Avatar
    Join Date
    Jul 2008
    Posts
    132
    Thanks
    10
    Thanked 1 Time in 1 Post
    Rep Power
    6

    Default Linux: NFS4 client unable to mount share

    Hi, I've followed nix guide how to setup nfs4, successfully setup nfs4 server but when I try to mount one of my guest (xen vm) I have this error on client side.

    mount -t nfs4 -o proto=tcp,port=2049,auto,rsize=1048576,wsize=10485 76,intr 192.168.0.81:/ /uploads

    mount.nfs4: Input/output error

    /var/log/messsages
    kernel: nfs: server 192.168.0.81 not responding, timed out

    Please help been banging my head the whole day to search for solution..

  2. #2
    Never say die nixcraft's Avatar
    Join Date
    Jan 2005
    Location
    BIOS
    Posts
    4,500
    Thanks
    17
    Thanked 789 Times in 507 Posts
    Rep Power
    10

    Default

    Do you've required ports open at the firewall level?
    All [Solved] threads are closed by mods / admin to avoid spam issues. See Howto mark a thread as [Solved]


  3. #3
    Senior Member t0kneneng's Avatar
    Join Date
    Jul 2008
    Posts
    132
    Thanks
    10
    Thanked 1 Time in 1 Post
    Rep Power
    6

    Default

    yes I've already open port 2049, even try to stop iptables.. still same error

  4. #4
    Senior Member t0kneneng's Avatar
    Join Date
    Jul 2008
    Posts
    132
    Thanks
    10
    Thanked 1 Time in 1 Post
    Rep Power
    6

    Default

    Ok... I did try setup here in our office same guide I follow, I mount client with no problem. But on my production server

    mount.nfs4: Input/outpot error.

    kernel: nfs: server 192.168.0.81 not responding, timed out

    On client side. On server I did try to tail logs I didn't see any incoming connection from client, Iptables stop just to make sure no issue on firewall.

    Client Guest(VM)
    My server is x3650 with centos 5.6 installed.

    On my production server I setup another machine, just to make sure it's not machine issue but on new nfs server setup same error. Client not mounting same error message also.

    Please help... couldn't find any solution on the net.

  5. #5
    Senior Member raj's Avatar
    Join Date
    Jun 2005
    Location
    Hyderabad
    Posts
    565
    Thanks
    57
    Thanked 40 Times in 37 Posts
    Rep Power
    13

    Default

    Post your nfs server config file /etc/exports, /etc/hosts.deny, and /etc/hosts.allow. From client run the following and post its output:
    Code:
    showmount -e
    showmount -d
    showmount -a  192.168.0.81
    Are you running nfs4 client services including portmap on client? Stop firewall on both client and server try mount command.
    Raj
    Linux rulz.
    I have never turned back in my life ; I shall not do so today.. haha

  6. #6
    Senior Member t0kneneng's Avatar
    Join Date
    Jul 2008
    Posts
    132
    Thanks
    10
    Thanked 1 Time in 1 Post
    Rep Power
    6

    Default

    [root@nfs3 ~]# cat /etc/exports
    /home/nfsuser/files 192.168.0.0/24(rw,sync,no_root_squash,fsid=0)

    [root@nfs3 ~]#showmount -e:
    /home/nfsuser/files 192.168.0.0/24

    [root@nfs3 ~]#showmount -d
    Directories on nfs3.localdomain:

    [root@nfs3 ~]# showmount -a 192.168.0.81
    All mount points on 192.168.0.81:

    [root@nfs3 ~]# cat /etc/hosts.allow
    #
    # hosts.allow This file describes the names of the hosts which are
    # allowed to use the local INET services, as decided
    # by the '/usr/sbin/tcpd' server.
    #
    portmap:192.168.1.0/24

    [root@nfs3 ~]# cat /etc/hosts.deny
    #
    # hosts.deny This file describes the names of the hosts which are
    # *not* allowed to use the local INET services, as decided
    # by the '/usr/sbin/tcpd' server.
    #
    # The portmap line is redundant, but it is left to remind you that
    # the new secure portmap uses hosts.deny and hosts.allow. In particular
    # you should know that NFS uses portmap!
    portmap:ALL

    ------Client------
    [root@static ~]# service portmap status
    portmap (pid 3405) is running..

    Tested client and nfsserver with iptables stop same error.

  7. #7
    Senior Member t0kneneng's Avatar
    Join Date
    Jul 2008
    Posts
    132
    Thanks
    10
    Thanked 1 Time in 1 Post
    Rep Power
    6

    Default

    any help please...

  8. #8
    Senior Member raj's Avatar
    Join Date
    Jun 2005
    Location
    Hyderabad
    Posts
    565
    Thanks
    57
    Thanked 40 Times in 37 Posts
    Rep Power
    13

    Default

    Why you blocked portmap in /etc/hosts.deny? This could be your problem. I suggest you stop all firewall and remove portmap and related entries from both files. Restart all services and try again. Also showmount should be run from the client computer and not from server itself.
    Raj
    Linux rulz.
    I have never turned back in my life ; I shall not do so today.. haha

  9. #9
    Senior Member t0kneneng's Avatar
    Join Date
    Jul 2008
    Posts
    132
    Thanks
    10
    Thanked 1 Time in 1 Post
    Rep Power
    6

    Default

    Ok stop all iptables on client and server,then restart all services. Also remove portmap on /etc/hosts.deny and /etc/hosts.allow

    [root@static ~]# showmount -a 192.168.0.81
    All mount points on 192.168.0.81:

    Server logs:
    May 5 14:02:37 nfs3 mountd[4820]: dump request from 192.168.0.165 failed.

    Mount:
    [root@static ~]# mount -t nfs4 -o proto=tcp,port=2049,acregmin=24,acregmax=240,acdir min=240,acdirmax=240,rsize=32768,wsize=32768,intr 192.168.0.81:/ /uploads
    mount.nfs4: Input/output error

    [root@static ~]# mount -t nfs4 -o proto=tcp,port=2049,rsize=32768,wsize=32768,intr 192.168.0.81:/ /uploads
    mount.nfs4: Input/output error

  10. #10
    Senior Member raj's Avatar
    Join Date
    Jun 2005
    Location
    Hyderabad
    Posts
    565
    Thanks
    57
    Thanked 40 Times in 37 Posts
    Rep Power
    13

    Default

    This command is not showing anything at all showmount -a 192.168.0.81. Are you mixing nfs3 and nfs4 exports? What about -e option?
    Code:
    showmount -e 192.168.0.81
    You should see list as folllows:
    Code:
    /images                   
    /cache                    
    /ftpin 
    /sftpin
    /Network Recycle Bin 1
    Also, run above and below one from nfs client system:
    Code:
    rpcinfo -p 192.168.0.81
    Both of them should display output. If not than make sure all nfs server including portmap running on server side as well as client side also. Finally, tcpdump may provide you more info:
    Code:
    tcpdump -n -s0 host 192.168.0.81
    Raj
    Linux rulz.
    I have never turned back in my life ; I shall not do so today.. haha

Thread Information

Users Browsing this Thread

There are currently 3 users browsing this thread. (0 members and 3 guests)

Similar Threads

  1. Can't mount NFS4 share
    By scott8035 in forum CentOS / RHEL / Fedora
    Replies: 2
    Last Post: 30th November 2011, 11:14 PM
  2. Linux Mount CIFS shares that contain spaces in their share name
    By stanners in forum Computer Networking and Internet/broadband
    Replies: 1
    Last Post: 12th March 2009, 08:16 PM
  3. Automatic Mount of Windows Share
    By bayvista in forum Networking, Firewalls and Security
    Replies: 0
    Last Post: 21st February 2008, 11:07 AM
  4. Kernel panic:unable to mount root fs
    By ajay.talk in forum Linux software
    Replies: 0
    Last Post: 22nd October 2007, 06:22 PM
  5. Linux Shell script to mount remote windows share
    By angelus_kit in forum Shell scripting
    Replies: 2
    Last Post: 6th September 2007, 07:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •