Results 1 to 2 of 2

Thread: make fails on nginx-0.8.49

  1. #1
    Junior Member
    Join Date
    May 2010
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Post make fails on nginx-0.8.49

    Greetings


    I am attempting to compile nginx-0.8.49 with the upstream fair module. The configure script seems to run ok with the following options:

    Code:
    #./configure --add-module=../upfair
    but when I run make it fails with this error:

    Code:
    objs/src/os/unix/ngx_process.o: In function `ngx_process_get_status':
    /mnt/store/src/nginx/SOURCES/nginx-0.8.49/src/os/unix/ngx_process.c:490: warning: `sys_errlist' is deprecated; use `strerror' or `strerror_r' instead
    /mnt/store/src/nginx/SOURCES/nginx-0.8.49/src/os/unix/ngx_process.c:490: warning: `sys_nerr' is deprecated; use `strerror' or `strerror_r' instead
    make[1]: Leaving directory `/mnt/store/src/nginx/SOURCES/nginx-0.8.49'
    I believe the above `sys_errlist' is deprecated; is actually normal. This is according to what I've found on the web and according to what I've heard in #nginx on freenode.

    Given this information, what I _really_ think is the problem may be the fact that make install produces this error:

    Code:
    root@LCENT01:/mnt/store/src/nginx/SOURCES/nginx-0.8.49]#make install
    make -f objs/Makefile install
    make[1]: Entering directory `/mnt/store/src/nginx/SOURCES/nginx-0.8.49'
    test -d '/usr/local/nginx' || mkdir -p '/usr/local/nginx'
    test -d '/usr/local/nginx/sbin'         || mkdir -p '/usr/local/nginx/sbin'
    test ! -f '/usr/local/nginx/sbin/nginx'         || mv '/usr/local/nginx/sbin/nginx'             '/usr/local/nginx/sbin/nginx.old'
    cp objs/nginx '/usr/local/nginx/sbin/nginx'
    test -d '/usr/local/nginx/conf'         || mkdir -p '/usr/local/nginx/conf'
    cp conf/koi-win '/usr/local/nginx/conf'
    cp conf/koi-utf '/usr/local/nginx/conf'
    cp conf/win-utf '/usr/local/nginx/conf'
    test -f '/usr/local/nginx/conf/mime.types'         || cp conf/mime.types '/usr/local/nginx/conf'
    cp conf/mime.types '/usr/local/nginx/conf/mime.types.default'
    test -f '/usr/local/nginx/conf/fastcgi_params'         || cp conf/fastcgi_params '/usr/local/nginx/conf'
    cp conf/fastcgi_params         '/usr/local/nginx/conf/fastcgi_params.default'
    test -f '/usr/local/nginx/conf/fastcgi.conf'         || cp conf/fastcgi.conf '/usr/local/nginx/conf'
    cp conf/fastcgi.conf '/usr/local/nginx/conf/fastcgi.conf.default'
    test -f '/usr/local/nginx/conf/uwsgi_params'         || cp conf/uwsgi_params '/usr/local/nginx/conf'
    cp conf/uwsgi_params         '/usr/local/nginx/conf/uwsgi_params.default'
    test -f '/usr/local/nginx/conf/scgi_params'         || cp conf/scgi_params '/usr/local/nginx/conf'
    cp conf/scgi_params         '/usr/local/nginx/conf/scgi_params.default'
    test -f '/usr/local/nginx/conf/nginx.conf'         || cp conf/nginx.conf '/usr/local/nginx/conf/nginx.conf'
    cp conf/nginx.conf '/usr/local/nginx/conf/nginx.conf.default'
    test -d '/usr/local/nginx/logs'         || mkdir -p '/usr/local/nginx/logs'
    test -d '/usr/local/nginx/logs' ||         mkdir -p '/usr/local/nginx/logs'
    test -d '/usr/local/nginx/html'         || cp -r html '/usr/local/nginx'
    test -d '/usr/local/nginx/logs' ||         mkdir -p '/usr/local/nginx/logs'
    make[1]: Leaving directory `/mnt/store/src/nginx/SOURCES/nginx-0.8.49'
    And if I try to start nginx this is what I get:

    Code:
    [root@LCENT01:/home/bluethundr]#service nginx start
    Starting nginx:                                           [FAILED]
    I am on CentOS 55 x86_64

    Code:
    [root@LCENT01:/home/bluethundr]#uname -a
    Linux LCENT01 2.6.18-194.11.3.el5xen #1 SMP Mon Aug 30 17:42:28 EDT 2010 i686 i686 i386 GNU/Linux
    [root@LCENT01:/home/bluethundr]#cat /etc/redhat-release 
    CentOS release 5.5 (Final)
    I would greatly appreciate any advice and effort that could help me get this going. Thanks in advance!!

  2. #2
    Never say die nixcraft's Avatar
    Join Date
    Jan 2005
    Location
    BIOS
    Posts
    4,515
    Thanks
    17
    Thanked 815 Times in 511 Posts
    Rep Power
    10

    Default

    service will only work when you install nginx using apt-get or other binary tool. Do not fix source and binary installations.
    All [Solved] threads are closed by mods / admin to avoid spam issues. See Howto mark a thread as [Solved]


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. What if iptables fails after a DROP all policy?
    By meowing in forum Networking, Firewalls and Security
    Replies: 2
    Last Post: 12th August 2009, 12:07 AM
  2. Samba PDC with Openldap--getent fails to show ldap accounts
    By nixcraftraj in forum Novell Suse / OpenSuse
    Replies: 0
    Last Post: 10th August 2009, 07:19 PM
  3. BASH Script To Send Email When Something Fails in The system
    By hudipirlo in forum Shell scripting
    Replies: 1
    Last Post: 17th April 2009, 10:40 AM
  4. Backup fails
    By meowing in forum Shell scripting
    Replies: 8
    Last Post: 29th April 2007, 06:09 PM
  5. Replies: 1
    Last Post: 12th December 2005, 10:42 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •