Results 1 to 3 of 3

Thread: kcore: Value too large for defined data type

  1. #1
    Junior Member
    Join Date
    Jul 2010
    Posts
    11
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Default kcore: Value too large for defined data type

    I get the error "kcore: Value too large for defined data type" when I try to install Landesk on a VM running OUL 5.4 64 bit.

    I know this is related to the fact that the file may be larger than 2gb but none of the files involved in the install of LD even come close. However the error message may be telling me what is wrong, kcore. It weighs in as follows:

    -r-------- 1 root root 2.1G Sep 2 09:52 kcore
    or
    -r-------- 1 root root 2147487744 Sep 2 09:53 kcore


    kcore, as I understand it, is an alias for the ram in the machine and takes up no disk space. /proc is built by the kernel for "reporting" for lack of a better term. Kcore is not matching ram exactly.

    free -m
    total used free shared buffers cached
    Mem: 2011 1402 608 0 204 694
    -/+ buffers/cache: 504 1506
    Swap: 1983 0 1983

    Can someone help me connect the dots?

  2. #2
    Never say die nixcraft's Avatar
    Join Date
    Jan 2005
    Location
    BIOS
    Posts
    4,513
    Thanks
    17
    Thanked 807 Times in 511 Posts
    Rep Power
    10

    Default

    It means that your version of the utilities were not compiled with large file support enabled. The GNU utilities do support large files if they are compiled to do so. You may want to compile them again and make sure that large file support is enabled. This support is automatically configured by autoconf on most systems. But it is possible that on your particular system it could not determine how to do that and therefore autoconf concluded that your system did not support large files.
    The message "Value too large for defined data type" is a system error message reported when an operation on a large file is attempted using a non-large file data type. Large files are defined as anything larger than a signed 32-bit integer, or stated differently, larger than 2GB.
    Many system calls that deal with files return values in a "long int" data type. On 32-bit hardware a long int is 32-bits and therefore this imposes a 2GB limit on the size of files. When this was invented that was HUGE and it was hard to conceive of needing anything that large. Time has passed and files can be much larger today. On native 64-bit systems the file size limit is usually 2GB * 2GB. Which we will again think is huge.
    On a 32-bit system with a 32-bit "long int" you find that you can't make it any bigger and also maintain compatibility with previous programs. Changing that would break many things! But many systems make it possible to switch into a new program mode which rewrites all of the file operations into a 64-bit program model. Instead of "long" they use a new data type called "off_t" which is constructed to be 64-bits in size. Program source code must be written to use the off_t data type instead of the long data type. This is typically done by defining -D_FILE_OFFSET_BITS=64 or some such. It is system dependent. Once done and once switched into this new mode most programs will support large files just fine.

    GNU Core Utilities Frequently Asked Questions
    All [Solved] threads are closed by mods / admin to avoid spam issues. See Howto mark a thread as [Solved]


  3. #3
    Junior Member
    Join Date
    Jul 2010
    Posts
    11
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Default

    I would tend to agree w/ your GNU tools info however I've used the same CD and kickstart on physical boxes w/o any problems. I think it's something specific to the VM's. I'm just not sure.

    My hopes were that the kcore file, being over 2GB, but not my much, would be the issue.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Solved] Value too large for defined data type
    By vampire in forum CentOS / RHEL / Fedora
    Replies: 2
    Last Post: 15th March 2010, 05:36 PM
  2. Replies: 1
    Last Post: 10th January 2010, 09:17 AM
  3. [Solved] Squid 2.7 Stable error - all not defined
    By bandcoach in forum Proxy Servers
    Replies: 3
    Last Post: 24th December 2009, 06:17 PM
  4. Type of ScSi adapter and Data written to tape
    By geekinput in forum Solaris/OpenSolaris
    Replies: 4
    Last Post: 11th November 2009, 10:08 AM
  5. Program gets aborted on large input
    By Ssk in forum Linux software
    Replies: 7
    Last Post: 14th March 2005, 11:04 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •