Results 1 to 5 of 5

Thread: My system does not put the hard drive in a low power state.

  1. #1
    Junior Member
    Join Date
    Jun 2010
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Default My system does not put the hard drive in a low power state.

    Hi:
    It is always spinning. Why is that? Thanks.

  2. #2
    Never say die nixcraft's Avatar
    Join Date
    Jan 2005
    Location
    BIOS
    Posts
    4,513
    Thanks
    17
    Thanked 804 Times in 511 Posts
    Rep Power
    10

    Default

    Yes, it is called spindown and not all hard drives supports it. Some time it is kernel and driver issue too. For example Seagate barracuda XT models with 64M cache supports spin down but other hard disk in same model does not supports it. Do you know make and model of your hard disk?
    All [Solved] threads are closed by mods / admin to avoid spam issues. See Howto mark a thread as [Solved]


  3. #3
    Junior Member
    Join Date
    Jun 2010
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Default

    Quote Originally Posted by nixcraft View Post
    Yes, it is called spindown and not all hard drives supports it. Some time it is kernel and driver issue too. For example Seagate barracuda XT models with 64M cache supports spin down but other hard disk in same model does not supports it. Do you know make and model of your hard disk?
    Thank you for your reply. At boot time the BIOS displays
    Primary Master: RM100-10 SAMSUNG SV4012H
    Primary Slave: 15.15M15 WDC WD100EB-00BHF0

    One thing I can say is that under MS-DOS version 5.00, the disks stop spinning after some period of inactivity on the keyboard. As DOS 5.00 knows nothing about ACPI, it is obviously the BIOS who stops the hard disks.

  4. #4
    Never say die nixcraft's Avatar
    Join Date
    Jan 2005
    Location
    BIOS
    Posts
    4,513
    Thanks
    17
    Thanked 804 Times in 511 Posts
    Rep Power
    10

    Default

    Yes, I believe SATA / SAS drives handle their own spindown features but it is kernel and/or other services who keep accessing hard disk. Most distro supports laptop mode and I think this can be applied to Slackware too. Another option is hdparm:

    Code:
    hdparm -S245 /dev/hda
    All [Solved] threads are closed by mods / admin to avoid spam issues. See Howto mark a thread as [Solved]


  5. #5
    Junior Member
    Join Date
    Jun 2010
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Default

    Thank you very much. BTW when I issue 'hdparm -B xxx', where xxx is a number, I get an I/O error. Why is that?
    P.S.: GNU/linux kernel 2.6, slackware 12.0, hdparm v7.6.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Power Managment in Linux system.
    By nix in forum Linux software
    Replies: 1
    Last Post: 14th April 2010, 04:45 PM
  2. Unresponsive hard disk head drive
    By 77yrold in forum Windows Xp/2000/2003 server administration
    Replies: 5
    Last Post: 18th September 2009, 06:41 PM
  3. USB hard drive
    By JATA01 in forum Linux hardware
    Replies: 0
    Last Post: 17th September 2008, 09:54 AM
  4. USB Hard Drive Multi-Boot
    By ceptune48 in forum Linux hardware
    Replies: 0
    Last Post: 31st December 2007, 04:26 PM
  5. Erase hard drive with Linux live CD
    By jerry in forum Linux software
    Replies: 1
    Last Post: 17th July 2006, 03:29 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •