Results 1 to 8 of 8

Thread: apache and mysql not running

  1. #1
    Member
    Join Date
    May 2009
    Location
    Thailand
    Posts
    50
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    6

    Question apache and mysql not running

    I reinstall Xampp 1.7.33 but when i start xampp at box show Apache and MySQL not running and when i try to open web localhost at page show
    IT WORK ! PLEASE GUIDE ME HOW TO FIX THIS PROBLEM
    Attached Images Attached Images

  2. #2
    Contributors jaysunn's Avatar
    Join Date
    Apr 2009
    Location
    NYC - USA
    Posts
    1,029
    Thanks
    165
    Thanked 154 Times in 133 Posts
    Rep Power
    24

    Default

    Xampp may not be running, you may be seeing httpd serving the localhost page. Apache and Xampp are different as you know.

    What is the output of this:


    Code:
    sudo /etc/init.d/apache2 status
    [sudo] password for jason: 
    Apache is running (pid xxxx)
    If this comes back with apache is running (pid xxx) then you are serving localhost from apache2 not xammp.

    Check the status of lampp. I think it is:

    Code:
    jason@kalturavideo1:~$ sudo /opt/lampp/lampp status
    [sudo] password for jason: 
    Version: XAMPP for Linux 1.7.1
    Apache is running.
    MySQL is running.
    ProFTPD is not running.
    Let us know the results.

    Jaysunn

  3. #3
    Member
    Join Date
    May 2009
    Location
    Thailand
    Posts
    50
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    6

    Default

    i check it from you guide . i got
    root@gooddog-desktop:~# /etc/init.d/apache2 status
    * Apache is running (pid 2279).

    and when i use xampp box start i got this

    root@gooddog-desktop:~# /opt/lampp/lampp status
    Version: XAMPP for Linux 1.7.3a
    Apache is not running.
    MySQL is not running.
    ProFTPD is running.

    that mean i running on apache2 and how to back to use Xampp ?
    please tell me .

  4. #4
    Contributors jaysunn's Avatar
    Join Date
    Apr 2009
    Location
    NYC - USA
    Posts
    1,029
    Thanks
    165
    Thanked 154 Times in 133 Posts
    Rep Power
    24

    Default

    Stop apache2:

    Code:
    root@gooddog-desktop:~#/etc/init.d/apache2 stop
    Start Xampp:
    Code:
    root@gooddog-desktop:~#/opt/lampp/lampp start

    Jaysunnn

  5. #5
    Member
    Join Date
    May 2009
    Location
    Thailand
    Posts
    50
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    6

    Default

    i stoped apache2 Xampp can running but Mysql not running when i go phpMyadmin it have error .

    root@gooddog-desktop:~# /opt/lampp/lampp start
    Starting XAMPP for Linux 1.7.3a...
    XAMPP: XAMPP-Apache is already running.
    XAMPP: Another MySQL daemon is already running.
    XAMPP: XAMPP-ProFTPD is already running.
    XAMPP for Linux started.

    i think that problem from i try to use command > sudo update-rc.d mysql defaults
    it make mysql error
    how to fix this problem ?
    Attached Images Attached Images
    Last edited by tonjaa; 7th April 2010 at 11:39 PM.

  6. #6
    Contributors jaysunn's Avatar
    Join Date
    Apr 2009
    Location
    NYC - USA
    Posts
    1,029
    Thanks
    165
    Thanked 154 Times in 133 Posts
    Rep Power
    24

    Default

    Please run these commands.

    Kill mysql not associated with xammp.

    Code:
    root@gooddog-desktop:~#sudo /etc/init.d/mysql stop

    Code:
    root@gooddog-desktop:~#sudo /opt/lampp/lampp stop
    Code:
    root@gooddog-desktop:~#sudo /opt/lampp/lampp start
    This should allow the xammp services to start, if you only want to run xammp you can remove the other services.

    Code:
    root@gooddog-desktop:~#sudo apt-get remove apache2
    Code:
    root@gooddog-desktop:~#sudo apt-get remove mysql
    This way they are not starting and running together.


    jaysunn

  7. #7
    Member
    Join Date
    May 2009
    Location
    Thailand
    Posts
    50
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    6

    Default

    thank you very much jaysunn now everything ok. i can use Xampp

  8. #8
    Contributors jaysunn's Avatar
    Join Date
    Apr 2009
    Location
    NYC - USA
    Posts
    1,029
    Thanks
    165
    Thanked 154 Times in 133 Posts
    Rep Power
    24

    Default [solved]

    Great News,

    Have a wonderful day...........


    Jaysunn

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Linux High Availability Apache, MySQL, PHP Clusters
    By navlepramod in forum High Availability Cluster
    Replies: 1
    Last Post: 23rd January 2010, 12:58 AM
  2. [Solved] web application not running
    By amarishvenugopal in forum Web servers
    Replies: 5
    Last Post: 31st December 2009, 09:39 AM
  3. [Solved] Freebsd Apache Mysql library issue
    By speederpro in forum Web servers
    Replies: 4
    Last Post: 26th August 2009, 02:02 AM
  4. CentOS Linux: Upgrading Apache php-mysq from 4 to 5 for MySQL 5
    By Danm in forum CentOS / RHEL / Fedora
    Replies: 3
    Last Post: 24th July 2009, 11:42 PM
  5. Apache + MySQL + Joomla crash...
    By alghouti in forum Web servers
    Replies: 1
    Last Post: 20th January 2009, 04:21 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •