Results 1 to 5 of 5

Thread: Postfix user accounts

  1. #1
    Junior Member
    Join Date
    Oct 2009
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Default Postfix user accounts

    I just finished setting up postfix as a gmail relay and as soon as I engage fetchmail, I notice (via mutt) that I didn't have a mail spool file for my current user account in /var/mail

    So I touched a file in that folder with my username and checked the permissions but it looks like Postfix still isn't writing out any mail to that spool.

    Any ideas on how to remedy this?

    Thanks.

  2. #2
    Contributors jaysunn's Avatar
    Join Date
    Apr 2009
    Location
    NYC - USA
    Posts
    1,027
    Thanks
    165
    Thanked 154 Times in 133 Posts
    Rep Power
    24

    Default

    Hello,

    Not sure if this is the case on Ubuntu. But RHEL postfix spool folders are located here:

    Code:
    [root@sugar ~]# cd /var/spool/mail/
    [root@sugar mail]# ls
    amalik  dbasantani  kchakraborty  kshenai  nprajapati  rrao  snishchay  sshukla  zheng
    [root@sugar mail]#

    Code:
    ---Mutt: /var/spool/mail/root [Msgs:0]---(date/date)-------------------------------------------------------------------------------------------------------------------------------------------------------------------------(all)---
    Mail sent.
    Jaysunn
    Last edited by jaysunn; 31st October 2009 at 06:38 PM.

  3. #3
    Junior Member
    Join Date
    Oct 2009
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Default

    hmm, /var/mail must symlink to /var/spool/mail on Ubuntu, just checked in that location and it seems to be the same story with the file. There's the file I created with my local user, but its still empty.

  4. #4
    Contributors jaysunn's Avatar
    Join Date
    Apr 2009
    Location
    NYC - USA
    Posts
    1,027
    Thanks
    165
    Thanked 154 Times in 133 Posts
    Rep Power
    24

    Default

    hmm,
    I checked this on RHEL, and the same. There must be a symlink for both locations.

    Code:
    /var/mail
    /var/spool/mail
    Very odd,
    I removed my root folder and was presented with this:

    Code:
    ---Mutt: (no mailbox) [Msgs:0]---(date/date)---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------(all)---
    /var/spool/mail/root: No such file or directory (errno = 2)
    Upon running:

    Code:
     touch /var/spool/mail/root
    I was good. Very odd. How is your drive space looking? Do you have space?

    Jaysunn

  5. #5
    Junior Member
    Join Date
    Oct 2009
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Default

    Yeah I have gigabytes of space left in that partition. Further, the root account is functioning normally (I'm getting the cronjob reports emailed to me).

    It might be worth mentioning that I have my /home partition segmented from the rest of the partitions and whenever I reinstall I rename the count the exact same thing as previous so all my settings migrate over.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Samba PDC with Openldap--getent fails to show ldap accounts
    By nixcraftraj in forum Novell Suse / OpenSuse
    Replies: 0
    Last Post: 10th August 2009, 06:19 PM
  2. Postfix User Mailbox Quota
    By jgijanto in forum Mail Servers
    Replies: 6
    Last Post: 9th May 2009, 02:52 AM
  3. Replies: 1
    Last Post: 2nd March 2009, 04:02 PM
  4. postfix one user multiple instance
    By irfan1234 in forum Mail Servers
    Replies: 0
    Last Post: 10th August 2008, 04:53 PM
  5. How do i create new email accounts in Postfix?
    By stoneiidol in forum Mail Servers
    Replies: 4
    Last Post: 5th August 2008, 09:02 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •