Results 1 to 2 of 2

Thread: Nagios Error-SSL handshaking Problem.

  1. #1
    Member
    Join Date
    Jul 2008
    Posts
    46
    Thanks
    1
    Thanked 1 Time in 1 Post
    Rep Power
    0

    Smile Nagios Error-SSL handshaking Problem.

    Hello Friends,

    I have 2 Linux Computers & installed nagios on both systems. Also I have configured

    nrpe-plugins
    nrpe-0.2.12

    on both linux computers.

    Everything is well performed & configured as per the official NRPE installation documentation. Locally , both nagios servers are working fine. Below is the result.

    /usr/local/nagios/libexec/check_nrpe -H localhost
    Output :- NRPE v2.12

    Same Output i am getting from another Linux PC.

    But, by typing
    /usr/local/nagios/libexec/./check_nrpe -H <ip add of remote linux pc>
    The output is :- CHECK_NRPE: Error - Could not complete SSL handshake.

    I have configured nrpe & nagios-plugins with "--enable-ssl" to avoid this "SSL" error,but the after installation, the "SSL Handshaking" error remains present.

    Also ACCEPTED IPTABLES Rule to allow 5666 Port.

    Here is another error if i use -n option below.
    /usr/local/nagios/libexec/./check_nrpe -H <ip add of remote linux pc> -n
    CHECK_NRPE: Error receiving data from daemon.
    CHECK_NRPE: Received 0 bytes from daemon. Check the remote server logs for error messages.



    Any Suggestions ??? Kindly Help me out. I am totally confused,bcoz i tried my best to sort out this problem.

    Waiting for a quick & +ve reply,

    Nishith Vyas

  2. #2
    Never say die nixcraft's Avatar
    Join Date
    Jan 2005
    Location
    BIOS
    Posts
    4,515
    Thanks
    17
    Thanked 815 Times in 511 Posts
    Rep Power
    10

    Default

    Hi,

    Try suggestion posted in the official website:
    View FAQ
    All [Solved] threads are closed by mods / admin to avoid spam issues. See Howto mark a thread as [Solved]


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Nagios - No output returned from plugin
    By nishith in forum Linux software
    Replies: 8
    Last Post: 5th July 2009, 08:47 PM
  2. Nagios on tomcat?
    By Vince-0 in forum Linux software
    Replies: 0
    Last Post: 22nd April 2008, 02:30 PM
  3. Monitoring FreeBSD Jails for Updates with Nagios?
    By igno2k in forum All about FreeBSD/OpenBSD/NetBSD
    Replies: 0
    Last Post: 12th November 2007, 09:05 PM
  4. Verify Fedora 7 ISO images to get rid of burn error problem
    By deonitin in forum Getting started tutorials
    Replies: 2
    Last Post: 26th July 2007, 05:41 PM
  5. MRTG cfgmaker Error SNMPwalk problem
    By manish_2479 in forum Networking, Firewalls and Security
    Replies: 0
    Last Post: 10th July 2007, 09:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •