Results 1 to 3 of 3

Thread: Fedora httpd not working

  1. #1
    Junior Member
    Join Date
    Aug 2008
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Unhappy Fedora httpd not working

    Hi,

    I'm a newby so forgive me if this is an absolute dumb question.

    I just installed fedora core 8 (also tried 9 with same result)
    with the webserver package enabled.

    When I first start linux httpd is NOT running although I am in runlevel 3 and there is a Sxxhttpd in the rc3.d directory.

    After starting httpd manually with /etc/rc.d/init.d/httpd start I get an [OK].

    ps aux | grep http results in:
    root 2695 0.1 1.0 27096 10560 ? Ss 16:09 0:01 /usr/sbin/httpd
    apache 2697 0.0 0.5 27096 5328 ? S 16:09 0:00 /usr/sbin/httpd
    apache 2698 0.0 0.5 27096 5328 ? S 16:09 0:00 /usr/sbin/httpd
    apache 2699 0.0 0.5 27096 5328 ? S 16:09 0:00 /usr/sbin/httpd
    apache 2700 0.0 0.5 27096 5328 ? S 16:09 0:00 /usr/sbin/httpd
    apache 2701 0.0 0.5 27096 5328 ? S 16:09 0:00 /usr/sbin/httpd
    apache 2702 0.0 0.5 27096 5328 ? S 16:09 0:00 /usr/sbin/httpd
    apache 2703 0.0 0.5 27096 5328 ? S 16:09 0:00 /usr/sbin/httpd
    apache 2704 0.0 0.5 27096 5328 ? S 16:09 0:00 /usr/sbin/httpd

    If I do : netstat -tulpn | grep 80 I get:

    tcp 0 0 10.0.1.80:80 0.0.0.0:* LISTEN 2695/httpd

    I created in the web root (/var/www/html) a simple webpage:
    <html><body>hi</body></html>

    If I run lynx on the server itself with:
    lynx localhost

    I get:
    Unable to connect to remote host

    Also connecting from another computer does not work.
    ponting a browser to <ipaddress> results in "Unable to reach host"

    I can ping the server, I can ssh to the server.

    So what am I missing?

    Kind regards,
    Werner

  2. #2
    Never say die nixcraft's Avatar
    Join Date
    Jan 2005
    Location
    BIOS
    Posts
    4,497
    Thanks
    17
    Thanked 787 Times in 506 Posts
    Rep Power
    10

    Default

    Hi,

    May be firewall is blocking port 80, enter following to disable firewall for testing purpose:
    Code:
    service iptables stop
    lynx localhost
    All [Solved] threads are closed by mods / admin to avoid spam issues. See Howto mark a thread as [Solved]


  3. #3
    Junior Member
    Join Date
    Aug 2008
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Smile Yesss. Thank you thank you thank you

    That did it.

    How could I have forgotten this.

    Thank you very much.
    My server is already behind a firewall so I completely disabled the firewall.

    lynx localhost didn't work but from an external machine I do get a nice webpage.

    Regards,
    Werner

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. httpd.conf deleted! How to re-generate? Any Scripts?
    By vivekv in forum Shell scripting
    Replies: 1
    Last Post: 17th July 2008, 05:13 PM
  2. httpd.conf deleted! How to re-generate?
    By vivekv in forum Getting started tutorials
    Replies: 2
    Last Post: 17th January 2008, 03:45 PM
  3. httpd process
    By vimalgoel in forum Getting started tutorials
    Replies: 1
    Last Post: 8th October 2007, 12:40 AM
  4. HTTPD dead but subsys locked
    By surmandal in forum Web servers
    Replies: 10
    Last Post: 31st July 2007, 08:53 AM
  5. logwatch httpd
    By kavi2 in forum Linux software
    Replies: 3
    Last Post: 22nd September 2005, 09:28 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •